# CVE-2026-19633: PostgreSQL Anonymizer: unprivileged masked users can execute code via operators, domain casts and view subqueries

> Unprivileged users can execute arbitrary code with elevated privileges via malicious operators, casts, or subqueries in PostgreSQL Anonymizer.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-m3j4-9g8h-24qh

## What is CVE-2026-19633?

CVE-2026-19633 is a high-severity code injection vulnerability in DALIBO PostgreSQL Anonymizer, published on 6 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the malicious code can run with elevated privileges. The issue is fixed in PostgreSQL Anonymizer 3.1.4 and later versions

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-19633?


## How do I fix CVE-2026-19633?

No fix has been published for CVE-2026-19633 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19633 being exploited?

There is no known exploitation of CVE-2026-19633 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19633 and fix it if it is affected.

What it is: CVE-2026-19633 is a high-severity code injection vulnerability in DALIBO PostgreSQL Anonymizer, published on 6 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19633 in the wild and no public exploit code.

Affected product: DALIBO PostgreSQL Anonymizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19633/ (Markdown: https://insights.sbomify.com/CVE-2026-19633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19633
- OSV: https://osv.dev/vulnerability/CVE-2026-19633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19633/
Summaries are generated and may contain mistakes; the official description above is the record.
