# CVE-2026-19643: Out-of-bounds read in the Base64 decoder in Amazon aws-sdk-cpp on signed-char platforms

> A remote authenticated user can crash applications using the AWS C++ SDK by sending crafted Base64 input, causing a denial of service.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-mxm9-xpf9-x66x

## What is CVE-2026-19643?

CVE-2026-19643 is a medium-severity denial of service vulnerability in aws-sdk-cpp, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An out-of-bounds read issue in the Base64 decoder in Amazon aws-sdk-cpp before 1.11.862, on some platforms, might allow a remote authenticated user to crash an application that processes crafted Base64-encoded input.

To remediate this issue, users should upgrade to version 1.11.862.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-19643?

It affects 1 product.


Products: Amazon Aws Software Development Kit.

## How do I fix CVE-2026-19643?

Upgrade to a fixed version.

## Is CVE-2026-19643 being exploited?

There is no known exploitation of CVE-2026-19643 in the wild and no public exploit code.

## Other vulnerabilities in aws-sdk-cpp

- [CVE-2018-19981](https://insights.sbomify.com/CVE-2018-19981/): Information disclosure in n/a (high 7.2)
- [CVE-2026-19642](https://insights.sbomify.com/CVE-2026-19642/): Out-of-bounds write in the Base64 decoder in Amazon aws-sdk-cpp (medium 6.0)
- [CVE-2023-51651](https://insights.sbomify.com/CVE-2023-51651/): Potential URI resolution path traversal in the AWS SDK for PHP (medium 6.0)
- [CVE-2022-4725](https://insights.sbomify.com/CVE-2022-4725/): AWS SDK XML Parser XpathUtils.java XpathUtils server-side request forgery (medium 5.5)
- [CVE-2022-2582](https://insights.sbomify.com/CVE-2022-2582/): Exposure of unencrypted plaintext hash in github.com/aws/aws-sdk-go (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19643 and fix it if it is affected.

What it is: CVE-2026-19643 is a medium-severity denial of service vulnerability in aws-sdk-cpp, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19643 in the wild and no public exploit code.

Affected product: aws-sdk-cpp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19643/ (Markdown: https://insights.sbomify.com/CVE-2026-19643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19643
- OSV: https://osv.dev/vulnerability/CVE-2026-19643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19643/
Summaries are generated and may contain mistakes; the official description above is the record.
