# CVE-2026-19730: Podman: podman: quadlet install --replace non-truncating write retains removed host-access directives

> Podman quadlet install --replace fails to truncate files, potentially retaining removed security directives or mounts, leading to unintended container exposure or privilege escalation.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 1 Oct 2026
- **Also known as:** AZL-103407, BELL-CVE-2026-19730, DEBIAN-CVE-2026-19730, GHSA-fx76-2j3w-2mx6, GO-2026-6588, MINI-56gp-xjjm-29j5, MINI-6gmq-8q5w-x3rh, MINI-pmgf-qpvv-gj5g, MINI-r4wr-2jfg-648v, MINI-x2g9-g5jm-p294, UBUNTU-CVE-2026-19730

## What is CVE-2026-19730?

CVE-2026-19730 is a medium-severity vulnerability in Red Hat Ansible Automation Platform 2, published on 13 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The 'podman quadlet install --replace' command opens the existing destination file with O_CREATE|O_WRONLY but omits O_TRUNC. When the initial reflink copy attempt fails (common on non-reflink-capable filesystems including many RHEL default XFS configurations), the fallback in ReflinkOrCopy uses io.Copy which performs a non-truncating write. If the original Quadlet is larger than the new Quadlet, the file is not truncated and content from the original is preserved. The command completes with no warning.

There is no risk of information leakage as the user already had access to the Quadlet in order to replace it, and in most cases, this would only lead to invalid Quadlet files. However, security-related options from the end of the old Quadlet could be included in the new Quadlet, and if the truncation resulted in a valid Quadlet file, this could result in undesirable behavior. For example, running podman quadlet install --replace to remove a single line from the end of a Quadlet - including security-sensitive content, like AddCapability - will fail, and the option will continue to be used. Further, with Volume Quadlets, this can include additional mounts which can cause content to be unintentionally exposed into containers. If, later, the image is updated then compromised content might be leaked to an attacker.

The vulnerable code paths are in pkg/domain/infra/abi/quadlet.go (lines 338-360, O_CREATE|O_WRONLY without O_TRUNC) and vendor/go.podman.io/storage/pkg/fileutils/reflink_linux.go (lines 12-19, non-truncating io.Copy fallback).

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2026-19730?

7 open source packages ship an affected version, including github.com/containers/podman/v5, github.com/containers/podman and github.com/containers/podman/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v5` | Go | From 5.7.0 | 5.8.6 |
| `github.com/containers/podman/v5` | Go | From 5.7.0 | 5.8.6 |
| `github.com/containers/podman/v5` | Go | From 5.7.0 | 5.8.6 |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v4` | Go | All versions | None |

## How do I fix CVE-2026-19730?

Upgrade github.com/containers/podman/v5 to 5.8.6 or later.

## Is CVE-2026-19730 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19730 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19730 and fix it if it is affected.

What it is: CVE-2026-19730 is a medium-severity vulnerability in Red Hat Ansible Automation Platform 2, published on 13 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19730 exists.

Affected packages and fixed versions:
- github.com/containers/podman/v5 (Go): affected from 5.7.0; fixed in 5.8.6
- github.com/containers/podman/v5 (Go): affected from 5.7.0; fixed in 5.8.6
- github.com/containers/podman/v5 (Go): affected from 5.7.0; fixed in 5.8.6
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19730/ (Markdown: https://insights.sbomify.com/CVE-2026-19730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19730
- OSV: https://osv.dev/vulnerability/CVE-2026-19730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19730/
Summaries are generated and may contain mistakes; the official description above is the record.
