{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer.","exploited":"There is no known exploitation of CVE-2026-19888 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.26.0 or later.","what":"CVE-2026-19888 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-19888 and fix it if it is affected.\n\nWhat it is: CVE-2026-19888 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-19888 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected all versions; fixed in 1.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-19888/ (Markdown: https://insights.sbomify.com/CVE-2026-19888/index.md)","id":"CVE-2026-19888","markdown":"https://insights.sbomify.com/CVE-2026-19888/index.md","name":"CVE-2026-19888","record":{"aliases":["AZL-103430","BIT-pgbouncer-2026-19888","DEBIAN-CVE-2026-19888","ECHO-0734-af85-f434","GHSA-w79m-39mq-x36c","MINI-v9j2-37r9-f7g3","UBUNTU-CVE-2026-19888"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PgBouncer connection pooler","requires_auth":"none","summary":"An unauthenticated remote attacker can crash the PgBouncer process via a malformed SCRAM message, terminating all pooled connections.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"Missing validation of a mandatory attribute in the SCRAM client-final-message parser in PgBouncer through 1.25.2 allows an unauthenticated remote attacker to crash the process. A malformed message can make the parser report success while leaving a required value unset, which is then dereferenced as a NULL pointer. The crash occurs before any credential is verified, so no valid account is required. Because PgBouncer serves all clients from a single process, this terminates every pooled connection.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NULL pointer dereference in SCRAM client-final-message parsing in PgBouncer","id":"CVE-2026-19888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"null_dereference","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Server-Side Request Forgery (SSRF) in GitLab AI Gateway","id":"CVE-2026-19889"},"packages":[{"ecosystem":"Bitnami","fixed":["1.26.0"],"introduced":["0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2026-19888"}],"prev":{"headline":"Deserialization in Welcart e-Commerce","id":"CVE-2026-19887"},"products":["PgBouncer"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["n/a"]},"summary":"An unauthenticated remote attacker can crash the PgBouncer process via a malformed SCRAM message, terminating all pooled connections.","url":"https://insights.sbomify.com/CVE-2026-19888/"}