# CVE-2026-19888: NULL pointer dereference in SCRAM client-final-message parsing in PgBouncer

> An unauthenticated remote attacker can crash the PgBouncer process via a malformed SCRAM message, terminating all pooled connections.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** AZL-103430, BIT-pgbouncer-2026-19888, DEBIAN-CVE-2026-19888, ECHO-0734-af85-f434, GHSA-w79m-39mq-x36c, MINI-v9j2-37r9-f7g3, UBUNTU-CVE-2026-19888

## What is CVE-2026-19888?

CVE-2026-19888 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing validation of a mandatory attribute in the SCRAM client-final-message parser in PgBouncer through 1.25.2 allows an unauthenticated remote attacker to crash the process. A malformed message can make the parser report success while leaving a required value unset, which is then dereferenced as a NULL pointer. The crash occurs before any credential is verified, so no valid account is required. Because PgBouncer serves all clients from a single process, this terminates every pooled connection.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-19888?

1 open source package ship an affected version, including pgbouncer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgbouncer` | Bitnami | All versions | 1.26.0 |

## How do I fix CVE-2026-19888?

Upgrade pgbouncer to 1.26.0 or later.

## Is CVE-2026-19888 being exploited?

There is no known exploitation of CVE-2026-19888 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19888 and fix it if it is affected.

What it is: CVE-2026-19888 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19888 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgbouncer (Bitnami): affected all versions; fixed in 1.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19888/ (Markdown: https://insights.sbomify.com/CVE-2026-19888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19888
- OSV: https://osv.dev/vulnerability/CVE-2026-19888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19888/
Summaries are generated and may contain mistakes; the official description above is the record.
