# CVE-2026-19898: VictoriaMetrics VMAuth Authentication Endpoint main.go requestHandler excessive authentication

> Attackers can bypass authentication rate limits in VictoriaMetrics VMAuth, potentially enabling brute-force attacks against the authentication endpoint.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-c7pm-322g-r9gf, GHSA-wmqf-q66j-3h4j

## What is CVE-2026-19898?

CVE-2026-19898 is a medium-severity vulnerability in VictoriaMetrics, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in VictoriaMetrics up to 1.146.0. Impacted is the function requestHandler of the file app/vmauth/main.go of the component VMAuth Authentication Endpoint. Performing a manipulation results in improper restriction of excessive authentication attempts. The attack is possible to be carried out remotely. The complexity of an attack is rather high. The exploitability is considered difficult. The exploit has been made public and could be used. Upgrading to version 1.147.0 is recommended to address this issue. The patch is named 119ba0fb5be8024d50c5ba946599b2e69e8803ea. Upgrading the affected component is recommended.

Weakness: CWE-799 (Improper Control of Interaction Frequency), CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-19898?


## How do I fix CVE-2026-19898?

No fix has been published for CVE-2026-19898 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19898 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19898 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19898 and fix it if it is affected.

What it is: CVE-2026-19898 is a medium-severity vulnerability in VictoriaMetrics, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19898 exists.

Affected product: VictoriaMetrics. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19898/ (Markdown: https://insights.sbomify.com/CVE-2026-19898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19898
- OSV: https://osv.dev/vulnerability/CVE-2026-19898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19898/
Summaries are generated and may contain mistakes; the official description above is the record.
