# CVE-2026-19926: Evergreen open-ils.fielder OpenSRF Service osrf-gateway-v1 sql injection

> Remote attackers can exploit SQL injection in the Evergreen ILS OpenSRF gateway to read or modify database contents.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-p2pw-xc8c-mvmj

## What is CVE-2026-19926?

CVE-2026-19926 is a medium-severity SQL injection vulnerability in Evergreen, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been found in Evergreen up to 3.14.11/3.15.11/3.16.5/3.17-beta1. The affected element is an unknown function of the file /osrf-gateway-v1 of the component open-ils.fielder OpenSRF Service. Such manipulation leads to sql injection. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.14.12, 3.15.12, 3.16.6 and 3.17-beta2 is sufficient to fix this issue. The affected component should be upgraded.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-19926?


## How do I fix CVE-2026-19926?

No fix has been published for CVE-2026-19926 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19926 being exploited?

There is no known exploitation of CVE-2026-19926 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19926 and fix it if it is affected.

What it is: CVE-2026-19926 is a medium-severity SQL injection vulnerability in Evergreen, published on 16 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19926 in the wild and no public exploit code.

Affected product: Evergreen. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19926/ (Markdown: https://insights.sbomify.com/CVE-2026-19926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19926
- OSV: https://osv.dev/vulnerability/CVE-2026-19926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19926/
Summaries are generated and may contain mistakes; the official description above is the record.
