# CVE-2026-19927: OpenBoxes Product Upload Endpoint ProductController.groovy upload server-side request forgery

> Remote attackers can exploit a server-side request forgery vulnerability in the product upload endpoint to access internal resources or bypass security controls.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-828r-3vx8-65wx, GHSA-vv7q-2wgr-7w2p

## What is CVE-2026-19927?

CVE-2026-19927 is a medium-severity server-side request forgery vulnerability in OpenBoxes, published on 16 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in OpenBoxes up to 0.9.7. The impacted element is the function Upload of the file grails-app/controllers/org/pih/warehouse/product/ProductController.groovy of the component Product Upload Endpoint. Performing a manipulation of the argument params.url results in server-side request forgery. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.9.8-hotfix1 and 0.9.8 is sufficient to resolve this issue. The patch is named a599007325efe780a21b3537ecce3ca25635c926. It is suggested to upgrade the affected component.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-19927?


## How do I fix CVE-2026-19927?

No fix has been published for CVE-2026-19927 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19927 being exploited?

There is no known exploitation of CVE-2026-19927 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19927 and fix it if it is affected.

What it is: CVE-2026-19927 is a medium-severity server-side request forgery vulnerability in OpenBoxes, published on 16 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19927 in the wild and no public exploit code.

Affected product: OpenBoxes. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19927/ (Markdown: https://insights.sbomify.com/CVE-2026-19927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19927
- OSV: https://osv.dev/vulnerability/CVE-2026-19927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19927/
Summaries are generated and may contain mistakes; the official description above is the record.
