{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19929 exists.","fix":"No fix has been published for CVE-2026-19929 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-19929 is a medium-severity code injection vulnerability in OpenBoxes, published on 16 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-19929 and fix it if it is affected.\n\nWhat it is: CVE-2026-19929 is a medium-severity code injection vulnerability in OpenBoxes, published on 16 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19929 exists.\n\nAffected product: OpenBoxes. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-19929/ (Markdown: https://insights.sbomify.com/CVE-2026-19929/index.md)","id":"CVE-2026-19929","markdown":"https://insights.sbomify.com/CVE-2026-19929/index.md","name":"CVE-2026-19929","record":{"aliases":["GHSA-8wxj-vghp-jpcq","GHSA-c7w5-449g-58mm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenBoxes inventory system","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via template injection in OpenBoxes DocumentController, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-791","name":"Incomplete Filtering of Special Elements"},{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"A vulnerability was identified in OpenBoxes up to 0.9.6. This impacts the function buildZebraTemplate of the file grails-app/controllers/org/pih/warehouse/core/DocumentController.groovy of the component Template Processing. The manipulation leads to improper neutralization of special elements used in a template engine. It is possible to initiate the attack remotely. The exploit is publicly available and might be used. Upgrading to version 0.9.8-hotfix1 and 0.9.8 will fix this issue. The identifier of the patch is deeac6a4a7aba86ce99c4bda37142e41d209293e. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"OpenBoxes Template Processing DocumentController.groovy buildZebraTemplate special elements in template engine","id":"CVE-2026-19929","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":10,"next":{"headline":"Dolibarr User Cloning card.php ldap injection","id":"CVE-2026-19930"},"packages":[],"prev":{"headline":"OpenBoxes Role Interceptor RoleInterceptor.groovy needManager privileges management","id":"CVE-2026-19928"},"products":["OpenBoxes"],"published":"2026-08-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via template injection in OpenBoxes DocumentController, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-19929/"}