CVE-2026-2003 PostgreSQL oidvector discloses a few bytes of memory
A database user can disclose a few bytes of server memory due to improper validation of the oidvector type in PostgreSQL.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2003?
CVE-2026-2003 is a medium-severity vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.
Weakness: CWE-1287
Which versions are affected by CVE-2026-2003?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-2003?
Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.
Is CVE-2026-2003 being exploited?
There is no known exploitation of CVE-2026-2003 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-2003, AZL-77420, AZL-77580, BELL-CVE-2026-2003, BIT-postgresql-2026-2003, CLEANSTART-2026-XG48192 and 13 more.