# CVE-2026-2003: PostgreSQL oidvector discloses a few bytes of memory

> A database user can disclose a few bytes of server memory due to improper validation of the oidvector type in PostgreSQL.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** ALPINE-CVE-2026-2003, AZL-77420, AZL-77580, BELL-CVE-2026-2003, BIT-postgresql-2026-2003, CLEANSTART-2026-XG48192, CLSA-2026-1773315820, CLSA-2026-1774258892, CLSA-2026-1774355598, DEBIAN-CVE-2026-2003, ECHO-fa09-83f6-e16f, GHSA-f3vj-j2m6-8hfj, JLSEC-2026-53, MINI-3mx2-xpmg-f7gw, MINI-4797-hjcg-pcff, MINI-4gmm-3pgg-xxmg, MINI-5cph-6538-9vwm, MINI-7r7r-5449-jcm2, MINI-9676-hv7j-9rwg

## What is CVE-2026-2003?

CVE-2026-2003 is a medium-severity vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory.  We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely.  Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-2003?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-2003?

Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.

## Is CVE-2026-2003 being exploited?

There is no known exploitation of CVE-2026-2003 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2003 and fix it if it is affected.

What it is: CVE-2026-2003 is a medium-severity vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2003 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2003/ (Markdown: https://insights.sbomify.com/CVE-2026-2003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2003
- OSV: https://osv.dev/vulnerability/CVE-2026-2003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2003/
Summaries are generated and may contain mistakes; the official description above is the record.
