CVE-2026-2004 PostgreSQL intarray missing validation of type of input to selectivity estimator executes arbitrary code
An attacker with object creation privileges can execute arbitrary code as the database user due to missing input validation in the intarray extension.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2004?
CVE-2026-2004 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.
Weakness: CWE-1287
Which versions are affected by CVE-2026-2004?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-2004?
Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-2004 being exploited?
There is no known exploitation of CVE-2026-2004 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-2004, AZL-77423, AZL-77583, BELL-CVE-2026-2004, BIT-postgresql-2026-2004, CLEANSTART-2026-DT63161 and 10 more.