{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-2004 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.","what":"CVE-2026-2004 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-2004 and fix it if it is affected.\n\nWhat it is: CVE-2026-2004 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-2004 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-2004/ (Markdown: https://insights.sbomify.com/CVE-2026-2004/index.md)","id":"CVE-2026-2004","markdown":"https://insights.sbomify.com/CVE-2026-2004/index.md","name":"CVE-2026-2004","record":{"aliases":["ALPINE-CVE-2026-2004","AZL-77423","AZL-77583","BELL-CVE-2026-2004","BIT-postgresql-2026-2004","CLEANSTART-2026-DT63161","DEBIAN-CVE-2026-2004","ECHO-8d2d-0ceb-b0f5","GHSA-qw3h-8vxv-jf6c","JLSEC-2026-54","MINI-56rh-463c-rh3h","MINI-8538-v53m-3g6w","MINI-gw76-w7wp-wxj7","MINI-hjh3-p452-jw87","MINI-hrwf-hchp-xj32","MINI-w527-cmvr-jxvh"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"An attacker with object creation privileges can execute arbitrary code as the database user due to missing input validation in the intarray extension.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1287","name":"Improper Validation of Specified Type of Input"}],"description":"Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the operating system user running the database.  Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL intarray missing validation of type of input to selectivity estimator executes arbitrary code","id":"CVE-2026-2004","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL pgcrypto heap buffer overflow executes arbitrary code","id":"CVE-2026-2005"},"packages":[{"ecosystem":"Bitnami","fixed":["14.21.0","15.16.0","16.12.0","17.8.0","18.2.0"],"introduced":["0","15.0.0","16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-2004"}],"prev":{"headline":"PostgreSQL oidvector discloses a few bytes of memory","id":"CVE-2026-2003"},"products":["PostgreSQL"],"published":"2026-02-12","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["n/a"]},"summary":"An attacker with object creation privileges can execute arbitrary code as the database user due to missing input validation in the intarray extension.","url":"https://insights.sbomify.com/CVE-2026-2004/"}