# CVE-2026-2004: PostgreSQL intarray missing validation of type of input to selectivity estimator executes arbitrary code

> An attacker with object creation privileges can execute arbitrary code as the database user due to missing input validation in the intarray extension.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-2004, AZL-77423, AZL-77583, BELL-CVE-2026-2004, BIT-postgresql-2026-2004, CLEANSTART-2026-DT63161, DEBIAN-CVE-2026-2004, ECHO-8d2d-0ceb-b0f5, GHSA-qw3h-8vxv-jf6c, JLSEC-2026-54, MINI-56rh-463c-rh3h, MINI-8538-v53m-3g6w, MINI-gw76-w7wp-wxj7, MINI-hjh3-p452-jw87, MINI-hrwf-hchp-xj32, MINI-w527-cmvr-jxvh

## What is CVE-2026-2004?

CVE-2026-2004 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the operating system user running the database.  Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-2004?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-2004?

Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.

## Is CVE-2026-2004 being exploited?

There is no known exploitation of CVE-2026-2004 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2004 and fix it if it is affected.

What it is: CVE-2026-2004 is a high-severity code injection vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2004 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2004/ (Markdown: https://insights.sbomify.com/CVE-2026-2004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2004
- OSV: https://osv.dev/vulnerability/CVE-2026-2004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2004/
Summaries are generated and may contain mistakes; the official description above is the record.
