CVE-2026-2005 PostgreSQL pgcrypto heap buffer overflow executes arbitrary code
A heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the database user.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2005?
CVE-2026-2005 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.
Which versions are affected by CVE-2026-2005?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-2005?
Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-2005 being exploited?
There is no known exploitation of CVE-2026-2005 in the wild and no public exploit code.
Public exploit code: 4 proofs of concept on GitHub.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-2005, AZL-77417, AZL-77586, BELL-CVE-2026-2005, BIT-postgresql-2026-2005, CLEANSTART-2026-CU35081 and 13 more.