{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-2005 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.","what":"CVE-2026-2005 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-2005 and fix it if it is affected.\n\nWhat it is: CVE-2026-2005 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-2005 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-2005/ (Markdown: https://insights.sbomify.com/CVE-2026-2005/index.md)","id":"CVE-2026-2005","markdown":"https://insights.sbomify.com/CVE-2026-2005/index.md","name":"CVE-2026-2005","record":{"aliases":["ALPINE-CVE-2026-2005","AZL-77417","AZL-77586","BELL-CVE-2026-2005","BIT-postgresql-2026-2005","CLEANSTART-2026-CU35081","CLSA-2026-1773330257","DEBIAN-CVE-2026-2005","ECHO-d29c-18a6-323f","GHSA-hgmp-6hmc-prfc","JLSEC-2026-55","MINI-3f46-287m-phh8","MINI-48vm-55rf-j4q3","MINI-cf7h-24p7-9827","MINI-rgm9-gx7v-g7fg","MINI-w6cr-r9q9-rfwf","MINI-wm93-9gvg-cqxj","UBUNTU-CVE-2026-2005","USN-8072-1"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"A heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the database user.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database.  Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-05-04","github_poc":4,"max_poc_stars":27,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-13T15:29:43Z","kind":"github_poc","ref":"https://github.com/var77/CVE-2026-2005","stars":27,"title":"PoC for CVE-2026-2005"},{"date":"2026-05-05T08:24:47Z","kind":"github_poc","ref":"https://github.com/dinosn/cve-2026-2005","stars":18,"title":"CVE-2026-2005 — PostgreSQL pgcrypto heap overflow RCE exploit"},{"date":"2026-05-04T17:37:03Z","kind":"github_poc","ref":"https://github.com/stvm8/CVE-2026-2005_lab","stars":0,"title":null},{"date":"2026-08-10T10:14:52Z","kind":"github_poc","ref":"https://github.com/open-flaw/CVE-2026-2005","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"PostgreSQL pgcrypto heap buffer overflow executes arbitrary code","id":"CVE-2026-2005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL missing validation of multibyte character length executes arbitrary code","id":"CVE-2026-2006"},"packages":[{"ecosystem":"Bitnami","fixed":["14.21.0","15.16.0","16.12.0","17.8.0","18.2.0"],"introduced":["0","15.0.0","16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-2005"}],"prev":{"headline":"PostgreSQL intarray missing validation of type of input to selectivity estimator executes arbitrary code","id":"CVE-2026-2004"},"products":["PostgreSQL"],"published":"2026-02-12","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["n/a"]},"summary":"A heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the database user.","url":"https://insights.sbomify.com/CVE-2026-2005/"}