# CVE-2026-2005: PostgreSQL pgcrypto heap buffer overflow executes arbitrary code

> A heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the database user.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-2005, AZL-77417, AZL-77586, BELL-CVE-2026-2005, BIT-postgresql-2026-2005, CLEANSTART-2026-CU35081, CLSA-2026-1773330257, DEBIAN-CVE-2026-2005, ECHO-d29c-18a6-323f, GHSA-hgmp-6hmc-prfc, JLSEC-2026-55, MINI-3f46-287m-phh8, MINI-48vm-55rf-j4q3, MINI-cf7h-24p7-9827, MINI-rgm9-gx7v-g7fg, MINI-w6cr-r9q9-rfwf, MINI-wm93-9gvg-cqxj, UBUNTU-CVE-2026-2005, USN-8072-1

## What is CVE-2026-2005?

CVE-2026-2005 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database.  Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-2005?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-2005?

Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.

## Is CVE-2026-2005 being exploited?

There is no known exploitation of CVE-2026-2005 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2026-2005 (github_poc): https://github.com/var77/CVE-2026-2005
- CVE-2026-2005 — PostgreSQL pgcrypto heap overflow RCE exploit (github_poc): https://github.com/dinosn/cve-2026-2005
- https://github.com/stvm8/CVE-2026-2005_lab (github_poc): https://github.com/stvm8/CVE-2026-2005_lab
- https://github.com/open-flaw/CVE-2026-2005 (github_poc): https://github.com/open-flaw/CVE-2026-2005

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2005 and fix it if it is affected.

What it is: CVE-2026-2005 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2005 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2005/ (Markdown: https://insights.sbomify.com/CVE-2026-2005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2005
- OSV: https://osv.dev/vulnerability/CVE-2026-2005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2005/
Summaries are generated and may contain mistakes; the official description above is the record.
