CVE-2026-2006 PostgreSQL missing validation of multibyte character length executes arbitrary code
A database user can execute arbitrary code via crafted queries due to missing multibyte character length validation in PostgreSQL.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2006?
CVE-2026-2006 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Missing validation of multibyte character length in PostgreSQL text manipulation allows a database user to issue crafted queries that achieve a buffer overrun. That suffices to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.
Which versions are affected by CVE-2026-2006?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |
Linux distribution packages (26)
postgresql16 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 18.3-150200.5.9.1 |
postgresql16 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 18.3-150200.5.9.1 |
postgresql16 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 18.3-150200.5.9.1 |
postgresql16 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 18.3-150200.5.9.1 |
postgresql18 SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 18.3-8.9.1 |
postgresql16 SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 18.3-150200.5.9.1 |
postgresql16 SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 18.3-150200.5.9.1 |
postgresql18 SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 18.3-8.9.1 |
postgresql16 SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 18.3-150200.5.9.1 |
postgresql16 SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 16.13-150200.5.41.1 |
postgresql17 SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 17.9-150200.5.25.1 |
postgresql18 SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 18.3-150200.5.9.1 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-2006?
Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-2006 being exploited?
There is no known exploitation of CVE-2026-2006 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-2006, AZL-77426, AZL-77589, AZL-77643, BELL-CVE-2026-2006, BIT-postgresql-2026-2006 and 16 more.