# CVE-2026-2006: PostgreSQL missing validation of multibyte character length executes arbitrary code

> A database user can execute arbitrary code via crafted queries due to missing multibyte character length validation in PostgreSQL.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-2006, AZL-77426, AZL-77589, AZL-77643, BELL-CVE-2026-2006, BIT-postgresql-2026-2006, CLEANSTART-2026-UF47808, CLSA-2026-1774017701, DEBIAN-CVE-2026-2006, ECHO-74f8-0c0f-635f, GHSA-mq5v-x68w-mc4f, JLSEC-2026-56, MINI-3mvw-743p-p89h, MINI-8948-336c-jxqf, MINI-f4jm-5gcw-wrrp, MINI-qqqc-gxgp-249h, MINI-r2g3-cxvm-rm4h, MINI-rv4f-cj7h-q55v, SUSE-SU-2026:0769-1, SUSE-SU-2026:0784-1, SUSE-SU-2026:0785-1, SUSE-SU-2026:0787-1

## What is CVE-2026-2006?

CVE-2026-2006 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing validation of multibyte character length in PostgreSQL text manipulation allows a database user to issue crafted queries that achieve a buffer overrun.  That suffices to execute arbitrary code as the operating system user running the database.  Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Weakness: CWE-1285 (Improper Validation of Specified Index, Position, or Offset in Input), CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-2006?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0 |
| `postgresql16` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 18.3-150200.5.9.1 |
| `postgresql16` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 18.3-150200.5.9.1 |
| `postgresql16` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 18.3-150200.5.9.1 |
| `postgresql16` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 18.3-150200.5.9.1 |
| `postgresql18` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 18.3-8.9.1 |
| `postgresql16` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 18.3-150200.5.9.1 |
| `postgresql16` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 18.3-150200.5.9.1 |
| `postgresql18` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 18.3-8.9.1 |
| `postgresql16` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 18.3-150200.5.9.1 |
| `postgresql16` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 16.13-150200.5.41.1 |
| `postgresql17` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 17.9-150200.5.25.1 |
| `postgresql18` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 18.3-150200.5.9.1 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-2006?

Upgrade postgresql to a fixed version for your release line: 14.21.0, 15.16.0, 16.12.0 or 17.8.0.

## Is CVE-2026-2006 being exploited?

There is no known exploitation of CVE-2026-2006 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2006 and fix it if it is affected.

What it is: CVE-2026-2006 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2006 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.21.0, 15.16.0, 16.12.0, 17.8.0, 18.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2006/ (Markdown: https://insights.sbomify.com/CVE-2026-2006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2006
- OSV: https://osv.dev/vulnerability/CVE-2026-2006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2006/
Summaries are generated and may contain mistakes; the official description above is the record.
