# CVE-2026-2007: PostgreSQL pg_trgm heap buffer overflow writes pattern onto server memory

> A heap buffer overflow in PostgreSQL pg_trgm allows attackers to write to server memory, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-2007, BELL-CVE-2026-2007, BIT-postgresql-2026-2007, DEBIAN-CVE-2026-2007, GHSA-5pr9-9395-q5gq, MINI-3mpx-33w2-j3j2, UBUNTU-CVE-2026-2007

## What is CVE-2026-2007?

CVE-2026-2007 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Heap buffer overflow in PostgreSQL pg_trgm allows a database user to achieve unknown impacts via a crafted input string.  The attacker has limited control over the byte patterns to be written, but we have not ruled out the viability of attacks that lead to privilege escalation.  PostgreSQL 18.1 and 18.0 are affected.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-2007?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 18.0.0 | 18.2.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-2007?

Upgrade postgresql to 18.2.0 or later.

## Is CVE-2026-2007 being exploited?

There is no known exploitation of CVE-2026-2007 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2007 and fix it if it is affected.

What it is: CVE-2026-2007 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2007 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 18.0.0; fixed in 18.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2007/ (Markdown: https://insights.sbomify.com/CVE-2026-2007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2007
- OSV: https://osv.dev/vulnerability/CVE-2026-2007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2007/
Summaries are generated and may contain mistakes; the official description above is the record.
