# CVE-2026-2033: MLflow Tracking Server Artifact Handler Directory Traversal Remote Code Execution Vulnerability

> Remote attackers can execute arbitrary code on MLflow Tracking Server via path traversal in artifact handling without authentication.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-q2r8-vmq7-fpx2, PYSEC-2026-2658

## What is CVE-2026-2033?

CVE-2026-2033 is a high-severity path traversal vulnerability in MLflow, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MLflow Tracking Server Artifact Handler Directory Traversal Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of MLflow Tracking Server. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of artifact file paths. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-26649.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-2033?

3 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |

## How do I fix CVE-2026-2033?

Upgrade mlflow to 3.8.0rc0 or later.

## Is CVE-2026-2033 being exploited?

There is no known exploitation of CVE-2026-2033 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2033 and fix it if it is affected.

What it is: CVE-2026-2033 is a high-severity path traversal vulnerability in MLflow, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2033 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2033/ (Markdown: https://insights.sbomify.com/CVE-2026-2033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2033
- OSV: https://osv.dev/vulnerability/CVE-2026-2033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2033/
Summaries are generated and may contain mistakes; the official description above is the record.
