CVE-2026-2052 Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

High 8.8 Published Updated

Authenticated contributors can execute arbitrary code on the server via unsafe eval() in Widget Options plugin display logic.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-2052?

CVE-2026-2052 is a high-severity code injection vulnerability in Marketing Fire, LLC Widget Options - Extended, published on 2 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

Weakness: CWE-94

Which versions are affected by CVE-2026-2052?

How do I fix CVE-2026-2052?

No fix has been published for CVE-2026-2052 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-2052 being exploited?

There is no known exploitation of CVE-2026-2052 in the wild and no public exploit code.

Sources

Also known as CVE-2025-8903, GHSA-g2qq-qv5m-hcgq.

Is CVE-2026-2052 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free