# CVE-2026-2052: Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

> Authenticated contributors can execute arbitrary code on the server via unsafe eval() in Widget Options plugin display logic.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 May 2026
- **Updated:** 4 May 2026
- **Also known as:** CVE-2025-8903, GHSA-g2qq-qv5m-hcgq

## What is CVE-2026-2052?

CVE-2026-2052 is a high-severity code injection vulnerability in Marketing Fire, LLC Widget Options - Extended, published on 2 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-2052?


## How do I fix CVE-2026-2052?

No fix has been published for CVE-2026-2052 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-2052 being exploited?

There is no known exploitation of CVE-2026-2052 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2052 and fix it if it is affected.

What it is: CVE-2026-2052 is a high-severity code injection vulnerability in Marketing Fire, LLC Widget Options - Extended, published on 2 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2052 in the wild and no public exploit code.

Affected product: Marketing Fire, LLC Widget Options - Extended. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2052/ (Markdown: https://insights.sbomify.com/CVE-2026-2052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2052
- OSV: https://osv.dev/vulnerability/CVE-2026-2052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2052/
Summaries are generated and may contain mistakes; the official description above is the record.
