# CVE-2026-2092: Keycloak-services: keycloak: unauthorized access via improper validation of encrypted saml assertions

> Attackers can bypass authentication in Keycloak SAML broker by injecting encrypted assertions when the response is unsigned, leading to unauthorized access.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-keycloak-2026-2092, ECHO-8c0b-1f50-633c, GHSA-794g-x443-36f7, MINI-8868-4x3j-888g, MINI-9wvp-p7v5-hmx4

## What is CVE-2026-2092?

CVE-2026-2092 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak. Keycloak's Security Assertion Markup Language (SAML) broker endpoint does not properly validate encrypted assertions when the overall SAML response is not signed. An attacker with a valid signed SAML assertion can exploit this by crafting a malicious SAML response. This allows the attacker to inject an encrypted assertion for an arbitrary principal, leading to unauthorized access and potential information disclosure.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-2092?

7 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.2.5 | None |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.2.5 | None |
| `org.keycloak:keycloak-services` | Maven | From 26.3.0 to 26.4.7 | None |
| `org.keycloak:keycloak-services` | Maven | From 26.3.0 to 26.4.7 | None |
| `org.keycloak:keycloak-services` | Maven | From 26.5.0 | 26.5.5 |
| `org.keycloak:keycloak-services` | Maven | From 26.5.0 | 26.5.5 |
| `keycloak` | Bitnami | From 26.2.0 | 26.2.14, 26.4.10 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-2092?

Upgrade org.keycloak:keycloak-services to 26.5.5 or later.

## Is CVE-2026-2092 being exploited?

There is no known exploitation of CVE-2026-2092 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2092 and fix it if it is affected.

What it is: CVE-2026-2092 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2092 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.2.5; no fix listed
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.2.5; no fix listed
- org.keycloak:keycloak-services (Maven): affected from 26.3.0 up to 26.4.7; no fix listed
- org.keycloak:keycloak-services (Maven): affected from 26.3.0 up to 26.4.7; no fix listed
- org.keycloak:keycloak-services (Maven): affected from 26.5.0; fixed in 26.5.5
- org.keycloak:keycloak-services (Maven): affected from 26.5.0; fixed in 26.5.5
- keycloak (Bitnami): affected from 26.2.0; fixed in 26.2.14, 26.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2092/ (Markdown: https://insights.sbomify.com/CVE-2026-2092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2092
- OSV: https://osv.dev/vulnerability/CVE-2026-2092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2092/
Summaries are generated and may contain mistakes; the official description above is the record.
