# CVE-2026-21226: Azure Core shared client library for Python Remote Code Execution Vulnerability

> An authorized attacker can execute arbitrary code remotely via unsafe deserialization in the Azure Core Python library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2026
- **Updated:** 30 Jul 2026
- **Also known as:** CLEANSTART-2026-DQ66117, CLEANSTART-2026-RG68334, ECHO-8823-3581-0fe0, GHSA-jm66-cg57-jjv5, MINI-cpgh-8xpx-ff7v, MINI-pf9c-2339-w953, MINI-v56f-mcq2-2mgm, MINI-v92h-fgq8-5827, MINI-xp6h-24pc-477f, PYSEC-2026-1208, ROOT-APP-PYPI-CVE-2026-21226, SUSE-SU-2026:0476-1, SUSE-SU-2026:20617-1, SUSE-SU-2026:20621-1, openSUSE-SU-2026:10161-1, openSUSE-SU-2026:20292-1

## What is CVE-2026-21226?

CVE-2026-21226 is a high-severity unsafe deserialization vulnerability in Microsoft Azure Core shared client library for Python, published on 13 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Deserialization of untrusted data in Azure Core shared client library for Python allows an authorized attacker to execute code over a network.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-21226?

3 open source packages ship an affected version, including azure-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `azure-core` | PyPI | All versions | 1.38.0 |
| `azure-core` | PyPI | All versions | 1.38.0 |
| `azure-core` | PyPI | All versions | 1.38.0 |
| `python-azure-core` | SUSE:Linux Enterprise High Availability Extension 16.0 | All versions | 1.32.0-160000.3.1 |
| `python-azure-core` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 1.30.0-150400.11.6.1 |
| `python-azure-core` | SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 1.30.0-150400.11.6.1 |
| `python-azure-core` | SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 1.30.0-150400.11.6.1 |
| `python-azure-core` | SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 1.30.0-150400.11.6.1 |
| `python-azure-core` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.32.0-160000.3.1 |
| `python-azure-core` | openSUSE:Leap 15.6 | All versions | 1.30.0-150400.11.6.1 |
| `python-azure-core` | openSUSE:Leap 16.0 | All versions | 1.32.0-160000.3.1 |
| `python-azure-core` | openSUSE:Tumbleweed | All versions | 1.38.0-2.1 |

Products: Microsoft Azure Core Shared Client Library.

## How do I fix CVE-2026-21226?

Upgrade azure-core to 1.38.0 or later.

## Is CVE-2026-21226 being exploited?

There is no known exploitation of CVE-2026-21226 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21226 and fix it if it is affected.

What it is: CVE-2026-21226 is a high-severity unsafe deserialization vulnerability in Microsoft Azure Core shared client library for Python, published on 13 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21226 in the wild and no public exploit code.

Affected packages and fixed versions:
- azure-core (PyPI): affected all versions; fixed in 1.38.0
- azure-core (PyPI): affected all versions; fixed in 1.38.0
- azure-core (PyPI): affected all versions; fixed in 1.38.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21226/ (Markdown: https://insights.sbomify.com/CVE-2026-21226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21226
- OSV: https://osv.dev/vulnerability/CVE-2026-21226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21226/
Summaries are generated and may contain mistakes; the official description above is the record.
