# CVE-2026-2130: BurtTheCoder mcp-maigret search_username index.ts command injection

> Remote attackers can execute arbitrary commands via the username argument in the search_username function of the mcp-maigret library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2026
- **Updated:** 23 Feb 2026
- **Also known as:** GHSA-2g7v-hghf-grg4

## What is CVE-2026-2130?

CVE-2026-2130 is a medium-severity command injection vulnerability in BurtTheCoder mcp-maigret, published on 8 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was determined in BurtTheCoder mcp-maigret up to 1.0.12. This affects an unknown part of the file src/index.ts of the component search_username. Executing a manipulation of the argument Username can lead to command injection. The attack may be launched remotely. Upgrading to version 1.0.13 is able to mitigate this issue. This patch is called b1ae073c4b3e789ab8de36dc6ca8111ae9399e7a. Upgrading the affected component is advised.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-2130?

2 open source packages ship an affected version, including mcp-maigret. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-maigret` | npm | All versions | 1.0.13 |
| `mcp-maigret` | npm | All versions | 1.0.13 |

Products: Burtthecoder Maigret Mcp Server.

## How do I fix CVE-2026-2130?

Upgrade mcp-maigret to 1.0.13 or later.

## Is CVE-2026-2130 being exploited?

There is no known exploitation of CVE-2026-2130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2130 and fix it if it is affected.

What it is: CVE-2026-2130 is a medium-severity command injection vulnerability in BurtTheCoder mcp-maigret, published on 8 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2130 in the wild and no public exploit code.

Affected packages and fixed versions:
- mcp-maigret (npm): affected all versions; fixed in 1.0.13
- mcp-maigret (npm): affected all versions; fixed in 1.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2130/ (Markdown: https://insights.sbomify.com/CVE-2026-2130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2130
- OSV: https://osv.dev/vulnerability/CVE-2026-2130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2130/
Summaries are generated and may contain mistakes; the official description above is the record.
