# CVE-2026-21437: eopkg vulnerable to package file list integrity bypass


- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:L/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 1 Jan 2026
- **Updated:** 2 Jan 2026
- **Also known as:** GHSA-hjp7-qwrj-6cc6

## What is CVE-2026-21437?

CVE-2026-21437 is a low-severity vulnerability in getsolus eopkg, published on 1 Jan 2026. 

### Official description

eopkg is a Solus package manager implemented in python3. In versions prior to 4.4.0, a malicious package could include files that are not tracked by `eopkg`. This requires the installation of a package from a malicious or compromised source. Files in such packages would not be shown by `lseopkg` and related tools. The issue has been fixed in v4.4.0. Users only installing packages from the Solus repositories are not affected.

Weakness: CWE-353 (Missing Support for Integrity Check)

## Which versions are affected by CVE-2026-21437?

It affects 1 product.


Products: Getsol Eopkg.

## How do I fix CVE-2026-21437?

No fix has been published for CVE-2026-21437 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-21437 being exploited?

There is no known exploitation of CVE-2026-21437 in the wild and no public exploit code.

Public exploit code:

- https://github.com/osmancanvural/CVE-2026-21437 (github_poc): https://github.com/osmancanvural/CVE-2026-21437

## Other vulnerabilities in getsolus eopkg

- [CVE-2026-21436](https://insights.sbomify.com/CVE-2026-21436/): eopkg has Path Traversal: '../filedir' vulnerability (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21437 and fix it if it is affected.

What it is: CVE-2026-21437 is a low-severity vulnerability in getsolus eopkg, published on 1 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2026-21437 in the wild and no public exploit code.

Affected product: getsolus eopkg. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21437/ (Markdown: https://insights.sbomify.com/CVE-2026-21437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21437
- OSV: https://osv.dev/vulnerability/CVE-2026-21437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21437/
Summaries are generated and may contain mistakes; the official description above is the record.
