# CVE-2026-21439: badkeys vulnerable to ASCII control character injection on console via malformed input


- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** GHSA-wjpc-4f29-83h3, PYSEC-2026-1212

## What is CVE-2026-21439?

CVE-2026-21439 is a low-severity vulnerability in badkeys, published on 5 Jan 2026. 

### Official description

badkeys is a tool and library for checking cryptographic public keys for known vulnerabilities. In versions 0.0.15 and below, an attacker may inject content with ASCII control characters like vertical tabs, ANSI escape sequences, etc., that can create misleading output of the badkeys command-line tool. This impacts scanning DKIM keys (both --dkim and --dkim-dns), SSH keys (--ssh-lines mode), and filenames in various modes. This issue is fixed in version 0.0.16.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-21439?

3 open source packages ship an affected version, including badkeys. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `badkeys` | PyPI | All versions | 0.0.16 |
| `badkeys` | PyPI | All versions | 0.0.16 |
| `badkeys` | PyPI | All versions | 0.0.16 |

Products: Badkeys Badkeys.

## How do I fix CVE-2026-21439?

Upgrade badkeys to 0.0.16 or later.

## Is CVE-2026-21439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21439 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21439 and fix it if it is affected.

What it is: CVE-2026-21439 is a low-severity vulnerability in badkeys, published on 5 Jan 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21439 exists.

Affected packages and fixed versions:
- badkeys (PyPI): affected all versions; fixed in 0.0.16
- badkeys (PyPI): affected all versions; fixed in 0.0.16
- badkeys (PyPI): affected all versions; fixed in 0.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21439/ (Markdown: https://insights.sbomify.com/CVE-2026-21439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21439
- OSV: https://osv.dev/vulnerability/CVE-2026-21439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21439/
Summaries are generated and may contain mistakes; the official description above is the record.
