# CVE-2026-21445: Langflow Missing Authentication on Critical API Endpoints

> Unauthenticated attackers can access sensitive user data and perform destructive operations on Langflow API endpoints due to missing authentication controls.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-c5cp-vx83-jhqx, PYSEC-2026-1524, PYSEC-2026-2571

## What is CVE-2026-21445?

CVE-2026-21445 is a high-severity missing authorization vulnerability in Langflow Langflow, published on 2 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to version 1.7.0.dev45, multiple critical API endpoints in Langflow are missing authentication controls. The issue allows any unauthenticated user to access sensitive user conversation data, transaction histories, and perform destructive operations including message deletion. This affects endpoints handling personal data and system operations that should require proper authorization. Version 1.7.0.dev45 contains a patch.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-21445?

6 open source packages ship an affected version, including langflow and langflow-base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.7.1 |
| `langflow` | PyPI | All versions | 1.7.1 |
| `langflow` | PyPI | All versions | 1.7.1 |
| `langflow-base` | PyPI | All versions | 0.7.1 |
| `langflow-base` | PyPI | All versions | 0.7.1 |
| `langflow-base` | PyPI | All versions | 0.7.1 |

Products: Langflow Langflow.

## How do I fix CVE-2026-21445?

Upgrade langflow to 1.7.1 or later.

## Is CVE-2026-21445 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21445 exists.

Public exploit code:

- Academic proof-of-concept demonstrating CVE-2026-21445 [LangFlow] for authorized security research. (github_poc): https://github.com/codeb0ssx/CVE-2026-21445-PoC
- Langflow - Broken Access Control (nuclei): http/cves/2026/CVE-2026-21445.yaml

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21445 and fix it if it is affected.

What it is: CVE-2026-21445 is a high-severity missing authorization vulnerability in Langflow Langflow, published on 2 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21445 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.7.1
- langflow (PyPI): affected all versions; fixed in 1.7.1
- langflow (PyPI): affected all versions; fixed in 1.7.1
- langflow-base (PyPI): affected all versions; fixed in 0.7.1
- langflow-base (PyPI): affected all versions; fixed in 0.7.1
- langflow-base (PyPI): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21445/ (Markdown: https://insights.sbomify.com/CVE-2026-21445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21445
- OSV: https://osv.dev/vulnerability/CVE-2026-21445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21445/
Summaries are generated and may contain mistakes; the official description above is the record.
