# CVE-2026-21448: Bagisto has Normal & Blind SSTI from low-privilege user when ordering product

> Low-privilege users can achieve remote code execution via server-side template injection during the product ordering process.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2026
- **Updated:** 2 Jan 2026
- **Also known as:** GHSA-5j4h-4f72-qpm6

## What is CVE-2026-21448?

CVE-2026-21448 is a high-severity code injection vulnerability in bagisto, published on 2 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bagisto is an open source laravel eCommerce platform. Versions prior to 2.3.10 are vulnerable to server-side template injection. When a normal customer orders any product, in the `add address` step they can inject a value to run in admin view. The issue can lead to remote code execution. Version 2.3.10 contains a patch.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-21448?

2 open source packages ship an affected version, including bagisto/bagisto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bagisto/bagisto` | Packagist | All versions | 2.3.10 |
| `bagisto/bagisto` | Packagist | All versions | 2.3.10 |

Products: Webkul Bagisto.

## How do I fix CVE-2026-21448?

Upgrade bagisto/bagisto to 2.3.10 or later.

## Is CVE-2026-21448 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21448 exists.

## Other vulnerabilities in bagisto

- [CVE-2026-21446](https://insights.sbomify.com/CVE-2026-21446/): Bagisto Missing Authentication on Installer API Endpoints (high 8.8)
- [CVE-2023-36237](https://insights.sbomify.com/CVE-2023-36237/): Bagisto Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2023-33570](https://insights.sbomify.com/CVE-2023-33570/): Code injection in n/a (high 8.8)
- [CVE-2019-16403](https://insights.sbomify.com/CVE-2019-16403/): Authorization Bypass Through User-Controlled Key in Bagisto (high 8.8)
- [CVE-2019-14933](https://insights.sbomify.com/CVE-2019-14933/): Bagisto CSRF Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21448 and fix it if it is affected.

What it is: CVE-2026-21448 is a high-severity code injection vulnerability in bagisto, published on 2 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21448 exists.

Affected packages and fixed versions:
- bagisto/bagisto (Packagist): affected all versions; fixed in 2.3.10
- bagisto/bagisto (Packagist): affected all versions; fixed in 2.3.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21448/ (Markdown: https://insights.sbomify.com/CVE-2026-21448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21448
- OSV: https://osv.dev/vulnerability/CVE-2026-21448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21448/
Summaries are generated and may contain mistakes; the official description above is the record.
