# CVE-2026-21483: listmonk Vulnerable to Stored XSS Leading to Admin Account Takeover

> Lower-privileged users can inject JavaScript into campaigns, leading to admin account takeover when super admins view the content.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2026
- **Updated:** 2 Jan 2026
- **Also known as:** GHSA-jmr4-p576-v565, GO-2026-4277

## What is CVE-2026-21483?

CVE-2026-21483 is a medium-severity cross-site scripting vulnerability in knadh listmonk, published on 2 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

listmonk is a standalone, self-hosted, newsletter and mailing list manager. Prior to version 6.0.0, lower-privileged user with campaign management permissions can inject malicious JavaScript into campaigns or templates. When a higher-privileged user (Super Admin) views or previews this content, the XSS executes in their browser context, allowing the attacker to perform privileged actions such as creating backdoor admin accounts. The attack can be weaponized via the public archive feature, where victims simply need to visit a link - no preview click required. Version 6.0.0 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-21483?

5 open source packages ship an affected version, including github.com/knadh/listmonk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/knadh/listmonk` | Go | All versions | 1.1.1-0.20251231125615-74dc5a01cfbb |
| `github.com/knadh/listmonk` | Go | All versions | 1.1.1-0.20251231125615-74dc5a01cfbb |
| `github.com/knadh/listmonk` | Go | All versions | 1.1.1-0.20251231125615-74dc5a01cfbb |
| `github.com/knadh/listmonk` | Go | From 1.1.1 | 6.0.0 |
| `github.com/knadh/listmonk` | Go | From 1.1.1 | 6.0.0 |

Products: Nadh Listmonk.

## How do I fix CVE-2026-21483?

Upgrade github.com/knadh/listmonk to a fixed version for your release line: 1.1.1-0.20251231125615-74dc5a01cfbb or 6.0.0.

## Is CVE-2026-21483 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21483 exists.

## Other vulnerabilities in knadh listmonk

- [CVE-2025-49136](https://insights.sbomify.com/CVE-2025-49136/): listmonk's Sprig template Injection vulnerability leads to reading of Environment Variable for low privilege user (critical 9.1)
- [CVE-2025-58430](https://insights.sbomify.com/CVE-2025-58430/): listmonk Vulnerable to CSRF to XSS Chain That Can Lead to Admin Account Takeover (high 8.6)
- [CVE-2026-34828](https://insights.sbomify.com/CVE-2026-34828/): listmonk: Active sessions remain valid after password reset and password change (high 7.1)
- [CVE-2025-46011](https://insights.sbomify.com/CVE-2025-46011/): SQL injection in n/a (medium 6.5)
- [CVE-2026-34584](https://insights.sbomify.com/CVE-2026-34584/): listmonk: Broken Access Control in CSV Import (Unauthorized List Assignment) (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21483 and fix it if it is affected.

What it is: CVE-2026-21483 is a medium-severity cross-site scripting vulnerability in knadh listmonk, published on 2 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21483 exists.

Affected packages and fixed versions:
- github.com/knadh/listmonk (Go): affected all versions; fixed in 1.1.1-0.20251231125615-74dc5a01cfbb
- github.com/knadh/listmonk (Go): affected all versions; fixed in 1.1.1-0.20251231125615-74dc5a01cfbb
- github.com/knadh/listmonk (Go): affected all versions; fixed in 1.1.1-0.20251231125615-74dc5a01cfbb
- github.com/knadh/listmonk (Go): affected from 1.1.1; fixed in 6.0.0
- github.com/knadh/listmonk (Go): affected from 1.1.1; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21483/ (Markdown: https://insights.sbomify.com/CVE-2026-21483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21483
- OSV: https://osv.dev/vulnerability/CVE-2026-21483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21483/
Summaries are generated and may contain mistakes; the official description above is the record.
