# CVE-2026-21531: Azure SDK for Python Remote Code Execution Vulnerability

> An attacker can execute arbitrary code remotely by exploiting unsafe deserialization in the Azure AI Language Authoring SDK.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-436v-jg82-p533, PYSEC-2026-289

## What is CVE-2026-21531?

CVE-2026-21531 is a critical unsafe deserialization vulnerability in Microsoft Azure AI Language Authoring, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of untrusted data in Azure SDK allows an unauthorized attacker to execute code over a network.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-21531?

3 open source packages ship an affected version, including azure-ai-language-conversations-authoring. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `azure-ai-language-conversations-authoring` | PyPI | All versions | 1.0.0b4 |
| `azure-ai-language-conversations-authoring` | PyPI | All versions | 1.0.0b4 |
| `azure-ai-language-conversations-authoring` | PyPI | All versions | 1.0.0b4 |

Products: Microsoft Azure Conversation Authoring Client Library.

## How do I fix CVE-2026-21531?

Upgrade azure-ai-language-conversations-authoring to 1.0.0b4 or later.

## Is CVE-2026-21531 being exploited?

There is no known exploitation of CVE-2026-21531 in the wild and no public exploit code.

Public exploit code:

- https://github.com/NetVanguard-cmd/CVE-2026-21531 (github_poc): https://github.com/NetVanguard-cmd/CVE-2026-21531

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21531 and fix it if it is affected.

What it is: CVE-2026-21531 is a critical unsafe deserialization vulnerability in Microsoft Azure AI Language Authoring, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21531 in the wild and no public exploit code.

Affected packages and fixed versions:
- azure-ai-language-conversations-authoring (PyPI): affected all versions; fixed in 1.0.0b4
- azure-ai-language-conversations-authoring (PyPI): affected all versions; fixed in 1.0.0b4
- azure-ai-language-conversations-authoring (PyPI): affected all versions; fixed in 1.0.0b4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21531/ (Markdown: https://insights.sbomify.com/CVE-2026-21531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21531
- OSV: https://osv.dev/vulnerability/CVE-2026-21531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21531/
Summaries are generated and may contain mistakes; the official description above is the record.
