# CVE-2026-21619: Unsafe Deserialization of Erlang Terms in hex_core

> Attackers can cause denial of service or execute code via unsafe deserialization of Erlang terms in hex_core, hex, and rebar3.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 27 May 2026
- **Also known as:** DEBIAN-CVE-2026-21619, EEF-CVE-2026-21619, GHSA-hx9w-f2w9-9g96, MGASA-2026-0196, UBUNTU-CVE-2026-21619

## What is CVE-2026-21619?

CVE-2026-21619 is a low-severity unsafe deserialization vulnerability in erlang hex, published on 27 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Uncontrolled Resource Consumption, Deserialization of Untrusted Data vulnerability in hexpm hex_core (hex_api modules), hexpm hex (mix_hex_api modules), erlang rebar3 (r3_hex_api modules) allows Object Injection, Excessive Allocation. This vulnerability is associated with program files src/hex_api.erl, src/mix_hex_api.erl, apps/rebar/src/vendored/r3_hex_api.erl and program routines hex_core:request/4, mix_hex_api:request/4, r3_hex_api:request/4.

This issue affects hex_core: from 0.1.0 before 0.12.1; hex: from 2.3.0 before 2.3.2; rebar3: from 3.9.1 before 3.27.0.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-21619?

3 open source packages ship an affected version, including hex_core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hex_core` | Hex | All versions | 0.12.1 |
| `hex_core` | Hex | All versions | 0.12.1 |
| `hex_core` | Hex | From 0.1.0 | 0.12.1 |

Products: Erlang Rebar3, Hex Hex, Hex Hex Core.

## How do I fix CVE-2026-21619?

Upgrade hex_core to 0.12.1 or later.

## Is CVE-2026-21619 being exploited?

There is no known exploitation of CVE-2026-21619 in the wild and no public exploit code.

## Other vulnerabilities in erlang hex

- [CVE-2020-13802](https://insights.sbomify.com/CVE-2020-13802/): Command injection in n/a (critical 9.8)
- [CVE-2019-1000014](https://insights.sbomify.com/CVE-2019-1000014/): Supply chain in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21619 and fix it if it is affected.

What it is: CVE-2026-21619 is a low-severity unsafe deserialization vulnerability in erlang hex, published on 27 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-21619 in the wild and no public exploit code.

Affected packages and fixed versions:
- hex_core (Hex): affected all versions; fixed in 0.12.1
- hex_core (Hex): affected all versions; fixed in 0.12.1
- hex_core (Hex): affected from 0.1.0; fixed in 0.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21619/ (Markdown: https://insights.sbomify.com/CVE-2026-21619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21619
- OSV: https://osv.dev/vulnerability/CVE-2026-21619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21619/
Summaries are generated and may contain mistakes; the official description above is the record.
