# CVE-2026-21636: Security feature bypass in node

> Node.js permission model flaw allows bypassing network restrictions via Unix Domain Sockets, enabling access to privileged local services.

- **Severity:** Medium 5.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** BIT-node-2026-21636, BIT-node-min-2026-21636, GHSA-7xhv-hcmf-4rfv, MINI-rwq9-8mm4-j8fq, UBUNTU-CVE-2026-21636

## What is CVE-2026-21636?

CVE-2026-21636 is a medium-severity vulnerability in Nodejs Node.js, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw in Node.js's permission model allows Unix Domain Socket (UDS) connections to bypass network restrictions when `--permission` is enabled. Even without `--allow-net`, attacker-controlled inputs (such as URLs or socketPath options) can connect to arbitrary local sockets via net, tls, or undici/fetch. This breaks the intended security boundary of the permission model and enables access to privileged local services, potentially leading to privilege escalation, data exposure, or local code execution.

* The issue affects users of the Node.js permission model on version v25.

In the moment of this vulnerability, network permissions (`--allow-net`) are still in the experimental phase.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-21636?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 25.0.0 | 25.3.0 |
| `node-min` | Bitnami | From 25.0.0 | 25.3.0 |

Products: Nodejs Node.js.

## How do I fix CVE-2026-21636?

Upgrade node to 25.3.0 or later.

## Is CVE-2026-21636 being exploited?

There is no known exploitation of CVE-2026-21636 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Pauldechassey/CVE-2026-21636 (github_poc): https://github.com/Pauldechassey/CVE-2026-21636

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21636 and fix it if it is affected.

What it is: CVE-2026-21636 is a medium-severity vulnerability in Nodejs Node.js, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21636 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 25.0.0; fixed in 25.3.0
- node-min (Bitnami): affected from 25.0.0; fixed in 25.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21636/ (Markdown: https://insights.sbomify.com/CVE-2026-21636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21636
- OSV: https://osv.dev/vulnerability/CVE-2026-21636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21636/
Summaries are generated and may contain mistakes; the official description above is the record.
