# CVE-2026-21711: Security feature bypass in node

> Attackers can bypass network restrictions in Node.js Permission Model to create local IPC endpoints when network access is disabled.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** BIT-node-2026-21711, BIT-node-min-2026-21711, GHSA-vcqx-cqfc-xc2r, MINI-8rfx-g9j3-xg28, UBUNTU-CVE-2026-21711

## What is CVE-2026-21711?

CVE-2026-21711 is a medium-severity vulnerability in Nodejs Node.js, published on 30 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw in Node.js Permission Model network enforcement leaves Unix Domain Socket (UDS) server operations without the required permission checks, while all comparable network paths correctly enforce them.

As a result, code running under `--permission` without `--allow-net` can create and expose local IPC endpoints, allowing communication with other processes on the same host outside of the intended network restriction boundary.

This vulnerability affects Node.js **25.x** processes using the Permission Model where `--allow-net` is intentionally omitted to restrict network access. Note that `--allow-net` is currently an experimental feature.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-21711?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 25.0.0 | 25.8.2 |
| `node-min` | Bitnami | From 25.0.0 | 25.8.2 |

Products: Nodejs Node.js.

## How do I fix CVE-2026-21711?

Upgrade node to 25.8.2 or later.

## Is CVE-2026-21711 being exploited?

There is no known exploitation of CVE-2026-21711 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21711 and fix it if it is affected.

What it is: CVE-2026-21711 is a medium-severity vulnerability in Nodejs Node.js, published on 30 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21711 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 25.0.0; fixed in 25.8.2
- node-min (Bitnami): affected from 25.0.0; fixed in 25.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21711/ (Markdown: https://insights.sbomify.com/CVE-2026-21711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21711
- OSV: https://osv.dev/vulnerability/CVE-2026-21711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21711/
Summaries are generated and may contain mistakes; the official description above is the record.
