# CVE-2026-21727: Grafana Correlations: Cross-Tenant Data Disclosure and Permanent Deletion via Legacy org_id=0 Record

> Attackers with datasource privileges can read and delete cross-tenant correlation data due to improper handling of legacy org_id=0 records.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 27 Aug 2026
- **Also known as:** BIT-grafana-2026-21727, CLSA-2026-1789289678, GHSA-p5x9-j974-rpfp, GO-2026-6664, MINI-3v3g-prc6-8w65, MINI-4wrj-fv72-gf9v, MINI-5hhj-j23c-2wm5, MINI-6672-c7f7-hqx8, MINI-78jm-59mr-284j, MINI-8gp5-cvf3-w674, MINI-8v23-c7hx-8xgh, MINI-fxcg-x8j4-69g9, MINI-h5fr-3cw6-9rg2, MINI-jg7g-vrh6-fhx7, MINI-jh96-rv44-cr6v, MINI-mg4f-c783-jr58, MINI-v6mp-579q-87mv, MINI-x5wp-7x27-wvfv, UBUNTU-CVE-2026-21727

## What is CVE-2026-21727?

CVE-2026-21727 is a low-severity missing authorization vulnerability in Grafana Grafana, published on 15 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A cross-tenant isolation vulnerability was found in Grafana’s Correlations feature affecting legacy correlation records. Due to a backward compatibility condition allowing org_id = 0 records to be returned across organizations, a user with datasource management privileges could read and permanently delete legacy correlation data belonging to another organization. This issue affects correlations created prior to Grafana 10.2 and is fixed in >=11.6.11, >=12.0.9, >=12.1.6, and >=12.2.4.

Thanks to Gyu-hyeok Lee (g2h) for reporting this vulnerability.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-21727?

4 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | All versions | 1.9.2-0.20260127141016-e702db6096e0 |
| `github.com/grafana/grafana` | Go | All versions | 1.9.2-0.20260127141016-e702db6096e0 |
| `grafana` | Bitnami | All versions | 11.6.11, 12.0.9, 12.1.6, 12.2.4, 12.3.3 |

Products: Grafana Grafana.

## How do I fix CVE-2026-21727?

Upgrade github.com/grafana/grafana to 1.9.2-0.20260127141016-e702db6096e0 or later.

## Is CVE-2026-21727 being exploited?

There is no known exploitation of CVE-2026-21727 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21727 and fix it if it is affected.

What it is: CVE-2026-21727 is a low-severity missing authorization vulnerability in Grafana Grafana, published on 15 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21727 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected all versions; fixed in 1.9.2-0.20260127141016-e702db6096e0
- github.com/grafana/grafana (Go): affected all versions; fixed in 1.9.2-0.20260127141016-e702db6096e0
- grafana (Bitnami): affected all versions; fixed in 11.6.11, 12.0.9, 12.1.6, 12.2.4, 12.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21727/ (Markdown: https://insights.sbomify.com/CVE-2026-21727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21727
- OSV: https://osv.dev/vulnerability/CVE-2026-21727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21727/
Summaries are generated and may contain mistakes; the official description above is the record.
