# CVE-2026-21852: Claude Code Leaks Data via Malicious Environment Configuration Before Trust Confirmation

> Malicious repositories can leak Anthropic API keys by triggering API requests before user trust confirmation in Claude Code.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** GHSA-jh7p-qr78-84p7

## What is CVE-2026-21852?

CVE-2026-21852 is a medium-severity vulnerability in anthropics claude-code, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Prior to version 2.0.65, vulnerability in Claude Code's project-load flow allowed malicious repositories to exfiltrate data including Anthropic API keys before users confirmed trust. An attacker-controlled repository could include a settings file that sets ANTHROPIC_BASE_URL to an attacker-controlled endpoint and when the repository was opened, Claude Code would read the configuration and immediately issue API requests before showing the trust prompt, potentially leaking the user's API keys. Users on standard Claude Code auto-update have received this fix already. Users performing manual updates are advised to update to version 2.0.65, which contains a patch, or to the latest version.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2026-21852?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.0.65 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.0.65 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-21852?

Upgrade @anthropic-ai/claude-code to 2.0.65 or later.

## Is CVE-2026-21852 being exploited?

There is no known exploitation of CVE-2026-21852 in the wild and no public exploit code.

Public exploit code:

- https://github.com/atiilla/CVE-2026-21852-PoC (github_poc): https://github.com/atiilla/CVE-2026-21852-PoC
- Scan a repo for AI-IDE config files that can trigger RCE via Claude Code hooks, Cursor rules, MCP auto-registration. Detects CVE-2025-59536, CVE-2026-21852, CVE-2026-30615 + Pillar Rules File Backdoor patterns. (github_poc): https://github.com/TreRB/ai-ide-config-guard
- Scan a repo's .claude/ config (settings.json hooks, MCP servers, env, allowed-tools) for the RCE & API-key-exfiltration footguns (CVE-2025-59536, CVE-2026-21852) that fire when you clone+open an untrusted repository. Static, zero-dep, local-first. (github_poc): https://github.com/Perufitlife/dotclaude-security
- Security scanner auditing Claude Code environments for CVE-2026-21852 pre-trust execution, hook hijacking, and eBPF lockdown. (github_poc): https://github.com/abhishek2512mishra/claude-code-security-audit

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21852 and fix it if it is affected.

What it is: CVE-2026-21852 is a medium-severity vulnerability in anthropics claude-code, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-21852 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.0.65
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.0.65

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21852/ (Markdown: https://insights.sbomify.com/CVE-2026-21852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21852
- OSV: https://osv.dev/vulnerability/CVE-2026-21852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21852/
Summaries are generated and may contain mistakes; the official description above is the record.
