# CVE-2026-21858: n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling

> Unauthenticated attackers can access server files via vulnerable form-based workflows in n8n, exposing sensitive information.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-v4pr-fm98-w9pg

## What is CVE-2026-21858?

CVE-2026-21858 is a critical path traversal vulnerability in N8n N8n, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Versions starting with 1.65.0 and below 1.121.0 enable an attacker to access files on the underlying server through execution of certain form-based workflows. A vulnerable workflow could grant access to an unauthenticated remote attacker, resulting in exposure of sensitive information stored on the system and may enable further compromise depending on deployment configuration and workflow usage. This issue is fixed in version 1.121.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-21858?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 1.65.0 | 1.121.0 |
| `n8n` | npm | From 1.65.0 | 1.121.0 |

Products: N8n N8n.

## How do I fix CVE-2026-21858?

Upgrade n8n to 1.121.0 or later.

## Is CVE-2026-21858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21858 exists.

Public exploit code:

- n8n Ni8mare - Unauthenticated Arbitrary File Read to RCE Chain (CVSS 10.0) (github_poc): https://github.com/Chocapikk/CVE-2026-21858
- 🛡️ Official AI Security Tool module for CVE-2026-21858 + CVE-2025-68613 (n8n "Ni8mare" Unauthenticated Arbitrary File Read & Expression Injection RCE Full Chain). (github_poc): https://github.com/ZeroDayEvil/CVE-2026-21858-n8n-FullChain
- Proof of Concept: CVE-2026-21858 is vulnerability on n8n where unauthenticated remote attackers can access sensitive files. (github_poc): https://github.com/sh4den/CVE-2026-21858
- Comprehensive vulnerability detection tool for n8n workflow automation instances. Detects the critical CVE-2026-21858 vulnerability (CVSS 10.0) without performing any exploitation. (github_poc): https://github.com/cropnet/Ni8mare
- https://github.com/sec-dojo-com/CVE-2026-21858 (github_poc): https://github.com/sec-dojo-com/CVE-2026-21858
- Ni8mare, n8n RCE (github_poc): https://github.com/EQSTLab/CVE-2026-21858

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)
- [CVE-2026-27493](https://insights.sbomify.com/CVE-2026-27493/): n8n has Unauthenticated Expression Evaluation via Form Node (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21858 and fix it if it is affected.

What it is: CVE-2026-21858 is a critical path traversal vulnerability in N8n N8n, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21858 exists.

Affected packages and fixed versions:
- n8n (npm): affected from 1.65.0; fixed in 1.121.0
- n8n (npm): affected from 1.65.0; fixed in 1.121.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21858/ (Markdown: https://insights.sbomify.com/CVE-2026-21858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21858
- OSV: https://osv.dev/vulnerability/CVE-2026-21858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21858/
Summaries are generated and may contain mistakes; the official description above is the record.
