# CVE-2026-21859: Mailpit Proxy Endpoint is Vulnerable to Server-Side Request Forgery (SSRF)

> Attackers can exploit the /proxy endpoint to access internal network resources via Server-Side Request Forgery in Mailpit.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** GHSA-8v65-47jx-7mfr, GO-2026-4284

## What is CVE-2026-21859?

CVE-2026-21859 is a medium-severity server-side request forgery vulnerability in axllent mailpit, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mailpit is an email testing tool and API for developers. Versions 1.28.0 and below have a Server-Side Request Forgery (SSRF) vulnerability in the /proxy endpoint, allowing attackers to make requests to internal network resources. The /proxy endpoint validates http:// and https:// schemes, but it does not block internal IP addresses, enabling attackers to access internal services and APIs. This vulnerability is limited to HTTP GET requests with minimal headers. The issue is fixed in version 1.28.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-21859?

3 open source packages ship an affected version, including github.com/axllent/mailpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/axllent/mailpit` | Go | All versions | 1.28.1 |
| `github.com/axllent/mailpit` | Go | All versions | 1.28.1 |
| `github.com/axllent/mailpit` | Go | All versions | 1.28.1 |

Products: Axllent Mailpit.

## How do I fix CVE-2026-21859?

Upgrade github.com/axllent/mailpit to 1.28.1 or later.

## Is CVE-2026-21859 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21859 exists.

Public exploit code:

- Mailpit < 1.28.3 - Server-Side Request Forgery (nuclei): http/cves/2026/CVE-2026-21859.yaml

## Other vulnerabilities in axllent mailpit

- [CVE-2026-45713](https://insights.sbomify.com/CVE-2026-45713/): Mailpit: Unauthenticated remote memory-exhaustion DoS via unlimited SMTP DATA and /api/v1/send body sizes (high 7.5)
- [CVE-2026-22689](https://insights.sbomify.com/CVE-2026-22689/): Mailpit is vulnerable to Cross-Site WebSocket Hijacking (CSWSH) allowing unauthenticated access to emails (medium 6.5)
- [CVE-2026-45711](https://insights.sbomify.com/CVE-2026-45711/): Mailpit: Path traversal & arbitrary file write in mailpit dump --http via attacker-controlled message IDs (medium 5.9)
- [CVE-2026-45712](https://insights.sbomify.com/CVE-2026-45712/): Mailpit: Concurrent map read & write in proxy CSS rewriter - remote unauth crash (fatal error: concurrent map read and map write) (medium 5.9)
- [CVE-2026-45709](https://insights.sbomify.com/CVE-2026-45709/): Mailpit has an incomplete fix for GHSA-6jxm: HTML check still permits SSRF to private/loopback/IMDS via missing IP-filter dialer (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21859 and fix it if it is affected.

What it is: CVE-2026-21859 is a medium-severity server-side request forgery vulnerability in axllent mailpit, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21859 exists.

Affected packages and fixed versions:
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.28.1
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.28.1
- github.com/axllent/mailpit (Go): affected all versions; fixed in 1.28.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21859/ (Markdown: https://insights.sbomify.com/CVE-2026-21859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21859
- OSV: https://osv.dev/vulnerability/CVE-2026-21859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21859/
Summaries are generated and may contain mistakes; the official description above is the record.
