CVE-2026-21863 Malformed Valkey Cluster bus message can lead to Remote DoS

High 7.5 Published Updated

A remote attacker can crash the Valkey database by sending a malformed cluster bus message, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-21863?

CVE-2026-21863 is a high-severity denial of service vulnerability in valkey-io valkey, published on 23 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Valkey is a distributed key-value database. Prior to versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12, a malicious actor with access to the Valkey clusterbus port can send an invalid packet that may cause an out bound read, which might result in the system crashing. The Valkey clusterbus packet processing code does not validate that a clusterbus ping extension packet is located within buffer of the clusterbus packet before attempting to read it. Versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12 fix the issue. As an additional mitigation, don't expose the cluster bus connection directly to end users, and protect the connection with its own network ACLs.

Weakness: CWE-125

Which versions are affected by CVE-2026-21863?

1 open source package ship an affected version, including valkey. It affects 1 product.

PackageAffectedFixed in
valkey BitnamiAll versions7.2.12, 8.0.7, 8.1.6, 9.0.2
Linux distribution packages (6)
valkey Red Hat:hummingbird:1All versions0:9.0.3-1.2.hum1
valkey-compat-redis Red Hat:hummingbird:1All versions0:9.0.3-1.2.hum1
valkey-compat-redis-devel Red Hat:hummingbird:1All versions0:9.0.3-1.2.hum1
valkey-devel Red Hat:hummingbird:1All versions0:9.0.3-1.2.hum1
valkey-doc Red Hat:hummingbird:1All versions0:9.0.3-1.2.hum1
valkey-rdma Red Hat:hummingbird:1All versions0:9.0.3-1.2.hum1

Products include Lfprojects Valkey.

How do I fix CVE-2026-21863?

Upgrade valkey to a fixed version for your release line: 7.2.12, 8.0.7, 8.1.6 or 9.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-21863 being exploited?

There is no known exploitation of CVE-2026-21863 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2026-21863, AZL-78320, BELL-CVE-2026-21863, BIT-valkey-2026-21863, DEBIAN-CVE-2026-21863, GHSA-c677-q3wr-gggq and 1 more.

Is CVE-2026-21863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free