# CVE-2026-21863: Malformed Valkey Cluster bus message can lead to Remote DoS

> A remote attacker can crash the Valkey database by sending a malformed cluster bus message, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-21863, AZL-78320, BELL-CVE-2026-21863, BIT-valkey-2026-21863, DEBIAN-CVE-2026-21863, GHSA-c677-q3wr-gggq, RHSA-2026:8753

## What is CVE-2026-21863?

CVE-2026-21863 is a high-severity denial of service vulnerability in valkey-io valkey, published on 23 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Valkey is a distributed key-value database. Prior to versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12, a malicious actor with access to the Valkey clusterbus port can send an invalid packet that may cause an out bound read, which might result in the system crashing. The Valkey clusterbus packet processing code does not validate that a clusterbus ping extension packet is located within buffer of the clusterbus packet before attempting to read it. Versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12 fix the issue. As an additional mitigation, don't expose the cluster bus connection directly to end users, and protect the connection with its own network ACLs.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-21863?

1 open source package ship an affected version, including valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `valkey` | Bitnami | All versions | 7.2.12, 8.0.7, 8.1.6, 9.0.2 |
| `valkey` | Red Hat:hummingbird:1 | All versions | 0:9.0.3-1.2.hum1 |
| `valkey-compat-redis` | Red Hat:hummingbird:1 | All versions | 0:9.0.3-1.2.hum1 |
| `valkey-compat-redis-devel` | Red Hat:hummingbird:1 | All versions | 0:9.0.3-1.2.hum1 |
| `valkey-devel` | Red Hat:hummingbird:1 | All versions | 0:9.0.3-1.2.hum1 |
| `valkey-doc` | Red Hat:hummingbird:1 | All versions | 0:9.0.3-1.2.hum1 |
| `valkey-rdma` | Red Hat:hummingbird:1 | All versions | 0:9.0.3-1.2.hum1 |

Products: Lfprojects Valkey.

## How do I fix CVE-2026-21863?

Upgrade valkey to a fixed version for your release line: 7.2.12, 8.0.7, 8.1.6 or 9.0.2.

## Is CVE-2026-21863 being exploited?

There is no known exploitation of CVE-2026-21863 in the wild and no public exploit code.

## Other vulnerabilities in valkey-io valkey

- [CVE-2025-49844](https://insights.sbomify.com/CVE-2025-49844/): Redis Lua Use-After-Free may lead to remote code execution (critical 10.0)
- [CVE-2025-67733](https://insights.sbomify.com/CVE-2025-67733/): Valkey Affected by RESP Protocol Injection via Lua error_reply (high 8.5)
- [CVE-2026-27623](https://insights.sbomify.com/CVE-2026-27623/): Valkey has Pre-Authentication DOS from malformed RESP request (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21863 and fix it if it is affected.

What it is: CVE-2026-21863 is a high-severity denial of service vulnerability in valkey-io valkey, published on 23 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21863 in the wild and no public exploit code.

Affected packages and fixed versions:
- valkey (Bitnami): affected all versions; fixed in 7.2.12, 8.0.7, 8.1.6, 9.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21863/ (Markdown: https://insights.sbomify.com/CVE-2026-21863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21863
- OSV: https://osv.dev/vulnerability/CVE-2026-21863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21863/
Summaries are generated and may contain mistakes; the official description above is the record.
