CVE-2026-21871 NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()

Medium 6.1 Published Updated

Attackers can execute arbitrary JavaScript in victims' browsers if developers pass untrusted input to specific navigation functions in NiceGUI.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-21871?

CVE-2026-21871 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

NiceGUI is a Python-based UI framework. From versions 2.13.0 to 3.4.1, there is a XSS risk in NiceGUI when developers pass attacker-controlled strings into ui.navigate.history.push() or ui.navigate.history.replace(). These helpers are documented as History API wrappers for updating the browser URL without page reload. However, if the URL argument is embedded into generated JavaScript without proper escaping, a crafted payload can break out of the intended string context and execute arbitrary JavaScript in the victim’s browser. Applications that do not pass untrusted input into ui.navigate.history.push/replace are not affected. This issue has been patched in version 3.5.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-21871?

3 open source packages ship an affected version, including nicegui. It affects 1 product.

PackageAffectedFixed in
nicegui PyPIFrom 2.13.03.5.0
nicegui PyPIFrom 2.13.03.5.0
nicegui PyPIFrom 2.13.03.5.0

Products include Zauberzeug Nicegui.

How do I fix CVE-2026-21871?

Upgrade nicegui to 3.5.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-21871 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21871 exists.

Sources

Also known as GHSA-7grm-h62g-5m97, PYSEC-2026-1698.

Is CVE-2026-21871 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free