CVE-2026-21872 NiceGUI apps are vulnerable to XSS which uses `ui.sub_pages` and render arbitrary user-provided links

Medium 6.1 Published Updated

An attacker can execute arbitrary JavaScript in a victim's browser via malicious links in NiceGUI sub-pages, requiring user interaction.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-21872?

CVE-2026-21872 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

NiceGUI is a Python-based UI framework. From versions 2.22.0 to 3.4.1, an unsafe implementation in the click event listener used by ui.sub_pages, combined with attacker-controlled link rendering on the page, causes XSS when the user actively clicks on the link. This issue has been patched in version 3.5.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-21872?

3 open source packages ship an affected version, including nicegui. It affects 1 product.

PackageAffectedFixed in
nicegui PyPIFrom 2.22.03.5.0
nicegui PyPIFrom 2.22.03.5.0
nicegui PyPIFrom 2.22.03.5.0

Products include Zauberzeug Nicegui.

How do I fix CVE-2026-21872?

Upgrade nicegui to 3.5.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-21872 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21872 exists.

Sources

Also known as GHSA-m7j5-rq9j-6jj9, PYSEC-2026-1701.

Is CVE-2026-21872 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free