{"answers":{"affected":"2 open source packages ship an affected version, including theshit.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21882 exists.","fix":"Upgrade theshit to 0.2.0 or later.","what":"CVE-2026-21882 is a high-severity vulnerability in AsfhtgkDavid theshit, published on 2 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-21882 and fix it if it is affected.\n\nWhat it is: CVE-2026-21882 is a high-severity vulnerability in AsfhtgkDavid theshit, published on 2 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21882 exists.\n\nAffected packages and fixed versions:\n- theshit (crates.io): affected all versions; fixed in 0.2.0\n- theshit (crates.io): affected all versions; fixed in 0.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-21882/ (Markdown: https://insights.sbomify.com/CVE-2026-21882/index.md)","id":"CVE-2026-21882","markdown":"https://insights.sbomify.com/CVE-2026-21882/index.md","name":"CVE-2026-21882","record":{"aliases":["GHSA-2j3p-gqw5-g59j"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"CLI command fixer","requires_auth":"none","summary":"Local attackers can escalate privileges via command re-execution due to improper privilege dropping in the theshit CLI utility.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-273","name":"Improper Check for Dropped Privileges"},{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-250","name":"Execution with Unnecessary Privileges"}],"description":"theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.2.0, improper privilege dropping allows local privilege escalation via command re-execution. This issue has been patched in version 0.2.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution","id":"CVE-2026-21882","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Bokeh server applications have Incomplete Origin Validation in WebSockets","id":"CVE-2026-21883"},"packages":[{"ecosystem":"crates.io","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"theshit","purl":null,"source":"GHSA-2j3p-gqw5-g59j"},{"ecosystem":"crates.io","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"theshit","purl":"pkg:cargo/theshit","source":"GHSA-2j3p-gqw5-g59j"}],"prev":{"headline":"Kanboard is Vulnerable to Reverse Proxy Authentication Bypass","id":"CVE-2026-21881"},"products":["theshit"],"published":"2026-03-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-02","vendors":["AsfhtgkDavid"]},"summary":"Local attackers can escalate privileges via command re-execution due to improper privilege dropping in the theshit CLI utility.","url":"https://insights.sbomify.com/CVE-2026-21882/"}