# CVE-2026-21882: theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution

> Local attackers can escalate privileges via command re-execution due to improper privilege dropping in the theshit CLI utility.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2026
- **Updated:** 2 Mar 2026
- **Also known as:** GHSA-2j3p-gqw5-g59j

## What is CVE-2026-21882?

CVE-2026-21882 is a high-severity vulnerability in AsfhtgkDavid theshit, published on 2 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.2.0, improper privilege dropping allows local privilege escalation via command re-execution. This issue has been patched in version 0.2.0.

Weakness: CWE-273 (Improper Check for Dropped Privileges), CWE-269 (Improper Privilege Management), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-21882?

2 open source packages ship an affected version, including theshit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `theshit` | crates.io | All versions | 0.2.0 |
| `theshit` | crates.io | All versions | 0.2.0 |

## How do I fix CVE-2026-21882?

Upgrade theshit to 0.2.0 or later.

## Is CVE-2026-21882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21882 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21882 and fix it if it is affected.

What it is: CVE-2026-21882 is a high-severity vulnerability in AsfhtgkDavid theshit, published on 2 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21882 exists.

Affected packages and fixed versions:
- theshit (crates.io): affected all versions; fixed in 0.2.0
- theshit (crates.io): affected all versions; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21882/ (Markdown: https://insights.sbomify.com/CVE-2026-21882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21882
- OSV: https://osv.dev/vulnerability/CVE-2026-21882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21882/
Summaries are generated and may contain mistakes; the official description above is the record.
