# CVE-2026-21884: React Router SSR XSS in ScrollRestoration

> Attackers can execute arbitrary JavaScript during server-side rendering if untrusted content generates ScrollRestoration keys in Framework Mode.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-8v8x-cx79-35w7, ROOT-APP-NPM-CVE-2026-21884

## What is CVE-2026-21884?

CVE-2026-21884 is a high-severity cross-site scripting vulnerability in remix-run react-router, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

React Router is a router for React. In @remix-run/react version prior to 2.17.3. and react-router 7.0.0 through 7.11.0, a XSS vulnerability exists in in React Router's <ScrollRestoration> API in Framework Mode when using the getKey/storageKey props during Server-Side Rendering which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the keys. There is no impact if server-side rendering in Framework Mode is disabled, or if Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>) is being used. This issue has been patched in @remix-run/react version 2.17.3 and react-router version 7.12.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-21884?

4 open source packages ship an affected version, including @remix-run/react and react-router. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@remix-run/react` | npm | All versions | 2.17.3 |
| `@remix-run/react` | npm | All versions | 2.17.3 |
| `react-router` | npm | From 7.0.0 | 7.12.0 |
| `react-router` | npm | From 7.0.0 | 7.12.0 |

Products: Shopify React-Router, Shopify Remix-Run\/React.

## How do I fix CVE-2026-21884?

Upgrade @remix-run/react to 2.17.3 or later.

## Is CVE-2026-21884 being exploited?

There is no known exploitation of CVE-2026-21884 in the wild and no public exploit code.

## Other vulnerabilities in remix-run react-router

- [CVE-2026-55685](https://insights.sbomify.com/CVE-2026-55685/): React Router: Unauthenticated Denial of Service via Inefficient Route Matching (high 8.7)
- [CVE-2026-42211](https://insights.sbomify.com/CVE-2026-42211/): React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE (high 8.1)
- [CVE-2026-33245](https://insights.sbomify.com/CVE-2026-33245/): React Router vulnerable to XSS in unstable RSC redirect handling via javascript: redirect targets (high 8.0)
- [CVE-2026-22029](https://insights.sbomify.com/CVE-2026-22029/): React Router vulnerable to XSS via Open Redirects (high 8.0)
- [CVE-2025-59057](https://insights.sbomify.com/CVE-2025-59057/): React Router has XSS Vulnerability (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21884 and fix it if it is affected.

What it is: CVE-2026-21884 is a high-severity cross-site scripting vulnerability in remix-run react-router, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-21884 in the wild and no public exploit code.

Affected packages and fixed versions:
- @remix-run/react (npm): affected all versions; fixed in 2.17.3
- @remix-run/react (npm): affected all versions; fixed in 2.17.3
- react-router (npm): affected from 7.0.0; fixed in 7.12.0
- react-router (npm): affected from 7.0.0; fixed in 7.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21884/ (Markdown: https://insights.sbomify.com/CVE-2026-21884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21884
- OSV: https://osv.dev/vulnerability/CVE-2026-21884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21884/
Summaries are generated and may contain mistakes; the official description above is the record.
