{"answers":{"affected":"3 open source packages ship an affected version, including parsl. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21892 exists.","fix":"Upgrade parsl to 2026.01.05 or later.","what":"CVE-2026-21892 is a medium-severity SQL injection vulnerability in parsl, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-21892 and fix it if it is affected.\n\nWhat it is: CVE-2026-21892 is a medium-severity SQL injection vulnerability in parsl, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-21892 exists.\n\nAffected packages and fixed versions:\n- parsl (PyPI): affected all versions; fixed in 2026.01.05\n- parsl (PyPI): affected all versions; fixed in 2026.01.05\n- parsl (PyPI): affected all versions; fixed in 2026.01.05\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-21892/ (Markdown: https://insights.sbomify.com/CVE-2026-21892/index.md)","id":"CVE-2026-21892","markdown":"https://insights.sbomify.com/CVE-2026-21892/index.md","name":"CVE-2026-21892","record":{"aliases":["DEBIAN-CVE-2026-21892","DSA-6099-1","GHSA-f2mf-q878-gh58","PYSEC-2026-1759","UBUNTU-CVE-2026-21892","USN-8505-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python parallel scripting library","requires_auth":"none","summary":"An unauthenticated attacker can inject SQL commands into the Parsl visualization dashboard via the workflow_id parameter, leading to data exfiltration or denial of service.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"parsl","vendor":"uchicago"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Parsl Monitoring Visualization Vulnerable to SQL Injection","id":"CVE-2026-21892","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"n8n Vulnerable to Command Injection in Community Package Installation","id":"CVE-2026-21893"},"packages":[{"ecosystem":"PyPI","fixed":["2026.01.05"],"introduced":["0"],"last_affected":[],"package":"parsl","purl":null,"source":"GHSA-f2mf-q878-gh58"},{"ecosystem":"PyPI","fixed":["2026.01.05"],"introduced":["0"],"last_affected":[],"package":"parsl","purl":"pkg:pypi/parsl","source":"GHSA-f2mf-q878-gh58"},{"ecosystem":"PyPI","fixed":["2026.01.05"],"introduced":["0"],"last_affected":[],"package":"parsl","purl":"pkg:pypi/parsl","source":"PYSEC-2026-1759"}],"prev":{"headline":"ZimaOS has Authentication Bypass via System-Level Username","id":"CVE-2026-21891"},"products":["parsl"],"published":"2026-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-08","vendors":["Parsl"]},"summary":"An unauthenticated attacker can inject SQL commands into the Parsl visualization dashboard via the workflow_id parameter, leading to data exfiltration or denial of service.","url":"https://insights.sbomify.com/CVE-2026-21892/"}