CVE-2026-21893 n8n Vulnerable to Command Injection in Community Package Installation

Critical 9.4 Published Updated

Authenticated administrators can execute arbitrary system commands on the host via community package installation in n8n.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-21893?

CVE-2026-21893 is a critical command injection vulnerability in N8n N8n, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.

Weakness: CWE-78, CWE-20

Which versions are affected by CVE-2026-21893?

2 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmFrom 0.187.01.120.3
n8n npmFrom 0.187.01.120.3

Products include N8n N8n.

How do I fix CVE-2026-21893?

Upgrade n8n to 1.120.3 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-21893 being exploited?

There is no known exploitation of CVE-2026-21893 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-7c4h-vh2m-743m.

Is CVE-2026-21893 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free