# CVE-2026-21893: n8n Vulnerable to Command Injection in Community Package Installation

> Authenticated administrators can execute arbitrary system commands on the host via community package installation in n8n.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-7c4h-vh2m-743m

## What is CVE-2026-21893?

CVE-2026-21893 is a critical command injection vulnerability in N8n N8n, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-21893?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 0.187.0 | 1.120.3 |
| `n8n` | npm | From 0.187.0 | 1.120.3 |

Products: N8n N8n.

## How do I fix CVE-2026-21893?

Upgrade n8n to 1.120.3 or later.

## Is CVE-2026-21893 being exploited?

There is no known exploitation of CVE-2026-21893 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-21893 and fix it if it is affected.

What it is: CVE-2026-21893 is a critical command injection vulnerability in N8n N8n, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-21893 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected from 0.187.0; fixed in 1.120.3
- n8n (npm): affected from 0.187.0; fixed in 1.120.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-21893/ (Markdown: https://insights.sbomify.com/CVE-2026-21893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-21893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-21893
- OSV: https://osv.dev/vulnerability/CVE-2026-21893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-21893/
Summaries are generated and may contain mistakes; the official description above is the record.
