CVE-2026-21894 n8n's Missing Stripe-Signature Verification Allows Unauthenticated Forged Webhooks

Medium 6.5 Published Updated

Unauthenticated attackers can forge Stripe webhooks to trigger workflows, potentially executing arbitrary logic or modifying data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-21894?

CVE-2026-21894 is a medium-severity authentication bypass vulnerability in N8n N8n, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

n8n is an open source workflow automation platform. In versions from 0.150.0 to before 2.2.2, an authentication bypass vulnerability in the Stripe Trigger node allows unauthenticated parties to trigger workflows by sending forged Stripe webhook events. The Stripe Trigger creates and stores a Stripe webhook signing secret when registering the webhook endpoint, but incoming webhook requests were not verified against this secret. As a result, any HTTP client that knows the webhook URL could send a POST request containing a matching event type, causing the workflow to execute as if a legitimate Stripe event had been received. This issue affects n8n users who have active workflows using the Stripe Trigger node. An attacker could potentially fake payment or subscription events and influence downstream workflow behavior. The practical risk is reduced by the fact that the webhook URL contains a high-entropy UUID; however, authenticated n8n users with access to the workflow can view this webhook ID. This issue has been patched in version 2.2.2. A temporary workaround for this issue involves users deactivating affected workflows or restricting access to workflows containing Stripe Trigger nodes to trusted users only.

Weakness: CWE-290

Which versions are affected by CVE-2026-21894?

2 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmFrom 0.150.02.2.2
n8n npmFrom 0.150.02.2.2

Products include N8n N8n.

How do I fix CVE-2026-21894?

Upgrade n8n to 2.2.2 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-21894 being exploited?

There is no known exploitation of CVE-2026-21894 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-jf52-3f2h-h9j5.

Is CVE-2026-21894 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free